............ Foro Excel
Si no lo has hecho aún: REGISTRATE!!!

activar una validaacion de datos dependiendo de un resultado

Ver el tema anterior Ver el tema siguiente Ir abajo

activar una validaacion de datos dependiendo de un resultado

Mensaje por moises melgar el Vie Jun 11, 2010 3:00 pm

hola de nuevo
tengo una celda que quiero que se pueda acceder datos si en una celda en especial tenga un cualquier resultado entonces lo que hice fue que le di validacion de datos y en opcion personalizada le di la sig formula......=h18="", con esto logre que si la celda h18 esta vacia no se pueda escribir datos en la celda en que le di la validacion pero aqui viene mi duda

como puedo hacer para que si en caso que en h18 le den una cantidada (que no este vacia);en la celda donde esta la validacion se coloque vacia o que este en cero)
avatar
moises melgar
Jr_Moderator

Masculino Cantidad de envíos : 557
Edad : 29
Ciudad - Pais : Coatzacoalcos - Mexico
Version de Excel : 2007 - 2010
Fecha de inscripción : 25/05/2010

Volver arriba Ir abajo

Re: activar una validaacion de datos dependiendo de un resultado

Mensaje por GalileoGali el Vie Jun 11, 2010 8:43 pm

En principio =h18="" exige que h18 este vacía y no como refieres, por ende no esta claro lo que buscas

_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional
avatar
GalileoGali
Admin

Masculino Cantidad de envíos : 1963
Edad : 62
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: activar una validaacion de datos dependiendo de un resultado

Mensaje por moises melgar el Sáb Jun 12, 2010 1:19 pm

si y tienes toda la razon
pero lo que intento hacer son como los programas contables

donde en un movimineto de poliza en las columnas donde colocas el importe del debe y del haber cuando se escribe un numero en cualquiera de las 2 columnas la otra se pone en cero (dando a entender que no se puede tener ambas celdas con importes, una con importe y otra en cero) y eso lo quiero hacer en excel.

y no puedo colocarles formulas por que se supone que en ellas se pueden colocar importes.
no se si se te ocurre una idea o un userform en visual que pueda usar??????
ah y se me olvidaba que ademas que yo las tengo en excel y en otra hoja con la formula sumar.si calculo los importes acumulados por cuenta
gracias de nuevo por la atencion prestada
avatar
moises melgar
Jr_Moderator

Masculino Cantidad de envíos : 557
Edad : 29
Ciudad - Pais : Coatzacoalcos - Mexico
Version de Excel : 2007 - 2010
Fecha de inscripción : 25/05/2010

Volver arriba Ir abajo

Re: activar una validaacion de datos dependiendo de un resultado

Mensaje por GalileoGali el Sáb Jun 12, 2010 2:02 pm

Puedes hacer una validacion que impida colocar cifras en ambos dsitintas de 0 en ambas columnas y tener los 0 ya puestos de antes, de lo contrario tendras que usar macrso.
Es principio de este foro no hacerle la macro a nadie, sino simplemente colaborar con alguna dificultad, lo mismo respectoa Userform
en A1 colocas validacion Personalizada
=SUMA(A1:B1) = A1
y en B1
=SUMA(A1:B1)=b1
y llena con "0" ambas celdas
y asi copias para abajo las celdas

_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional
avatar
GalileoGali
Admin

Masculino Cantidad de envíos : 1963
Edad : 62
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: activar una validaacion de datos dependiendo de un resultado

Mensaje por moises melgar el Sáb Jun 12, 2010 2:07 pm

es cierto............
tienes toda la razon sumas las celda y que de resultado la misma celda para que de resultado cero en ambas
gracias de nuevo, se nota el nivel cuando se ve

tienes mucha experiencia y espero poder algun dia unirme como un maestro de la programacion asi como ustedes por lo que siguire estudiando y practicando en beneficio de todos
avatar
moises melgar
Jr_Moderator

Masculino Cantidad de envíos : 557
Edad : 29
Ciudad - Pais : Coatzacoalcos - Mexico
Version de Excel : 2007 - 2010
Fecha de inscripción : 25/05/2010

Volver arriba Ir abajo

Re: activar una validaacion de datos dependiendo de un resultado

Mensaje por Contenido patrocinado


Contenido patrocinado


Volver arriba Ir abajo

Ver el tema anterior Ver el tema siguiente Volver arriba


 
Permisos de este foro:
No puedes responder a temas en este foro.