............ Foro Excel
Si no lo has hecho aún: REGISTRATE!!!

Buscar valor de celda de hoja 1 en rango de celdas de hoja3

Ver el tema anterior Ver el tema siguiente Ir abajo

Buscar valor de celda de hoja 1 en rango de celdas de hoja3

Mensaje por jun_pab el Jue Ago 05, 2010 7:09 pm

Hola soy nuevo en el trabajo con excel y quisiera ver si me pueden ayudar.
Necesito buscar (al momento de presionar enter), el valor de una celda de la hoja 1, en un rango de celdas de la hoja3, si encuentro el valor ejecuto una macro y sino mando una mensaje de error.
Probe con esto y me manda un error :

If Worksheets("hoja1").Range("b4") = Worksheets("hoja3").Range("a2:a44") Then
Macro3
Else
MsgBox ("codigo no existe")
End if

Hice esta formula en excel y me funciona, pero lo que quiero es evitar que se ejecute una macro si no exite el código

=SI($B$4="";"";(SI.ERROR(BUSCARV($B$4;Hoja3!$A$1:$B$100;1;FALSO);"No existe el producto")))

Bueno espero que me puedan ayudar y tambien si pudiera validar que la celda no este vacia, seria perfecto.
Muchas gracias por su tiempo y ayuda.

Salu2


jun_pab

Masculino Cantidad de envíos : 11
Edad : 34
Ciudad - Pais : Santiago - Chile
Version de Excel : 2003 y 2007
Fecha de inscripción : 05/08/2010

Volver arriba Ir abajo

Re: Buscar valor de celda de hoja 1 en rango de celdas de hoja3

Mensaje por GalileoGali el Jue Ago 05, 2010 7:48 pm

A ver si esto

Código:
Sub test()
If Application.CountIf(Worksheets("Hoja3").Range("A2:A44"), Worksheets("Hoja1").Range("B4")) > 0 Then
Macro3
Else
MsgBox ("codigo no existe")
End If

_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional

GalileoGali
Admin

Masculino Cantidad de envíos : 1962
Edad : 61
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: Buscar valor de celda de hoja 1 en rango de celdas de hoja3

Mensaje por jun_pab el Vie Ago 06, 2010 1:21 am

Gracias Galileo, era justo lo que necesitaba.

salu2


jun_pab

Masculino Cantidad de envíos : 11
Edad : 34
Ciudad - Pais : Santiago - Chile
Version de Excel : 2003 y 2007
Fecha de inscripción : 05/08/2010

Volver arriba Ir abajo

Re: Buscar valor de celda de hoja 1 en rango de celdas de hoja3

Mensaje por Contenido patrocinado Hoy a las 1:56 am


Contenido patrocinado


Volver arriba Ir abajo

Ver el tema anterior Ver el tema siguiente Volver arriba


 
Permisos de este foro:
No puedes responder a temas en este foro.