............ Foro Excel
Si no lo has hecho aún: REGISTRATE!!!

problema con suma producto

Ver el tema anterior Ver el tema siguiente Ir abajo

problema con suma producto

Mensaje por grema90 el Mar Sep 28, 2010 4:34 am

Creo que con el ejemplo se entiende perfectamente lo que quiero.

Gracias por este nuevo foro, hacia tiempo que no sabia de Gali.

Hoja1

 BCDE
615-Maysipera, manzana, platano15
715-Febnopera, manzana40
813-Mar uva20
920-Junsiuva, manzana12
10    
1115-Ene   
12    
130   
Spreadsheet Formulas
CellFormula
B13=SUMAPRODUCTO((B6:B9>B11)*(C6:C9="SI")*(D6:D9="*"&"pera"&"*");--(E6:E9))


Excel tables to the web >> [Tienes que estar registrado y conectado para ver este vínculo]

esto tendria que salir 15, pero el tema de la columna d no lo hace.

grema90

Masculino Cantidad de envíos : 16
Edad : 52
Ciudad - Pais : españa
Version de Excel : excell 2007
Fecha de inscripción : 28/09/2010

Volver arriba Ir abajo

Re: problema con suma producto

Mensaje por grema90 el Mar Sep 28, 2010 5:47 am

Al final lo he solucionado con sumar.si.conjunto esta formula es nueva en excel 2007 y realmente muy util, jamas la habia usado

Gracias

grema90

Masculino Cantidad de envíos : 16
Edad : 52
Ciudad - Pais : españa
Version de Excel : excell 2007
Fecha de inscripción : 28/09/2010

Volver arriba Ir abajo

Re: problema con suma producto

Mensaje por GalileoGali el Mar Sep 28, 2010 7:37 am

La limitacion de SUMAPRODUCTO con los comodines, puede resolverse con ESNUMERO(HALLAR

Hoja1

 BCDEFG
615-Maysipera, manzana, platano15 15-Ene
715-Febnopera, manzana40  
813-Mar uva20 15
920-Junsiuva, manzana12  
Spreadsheet Formulas
CellFormula
G8=SUMAPRODUCTO((B6:B9>G6)*(C6:C9="SI")*ESNUMERO(HALLAR("pera";D6:D9));(E6:E9))


Excel tables to the web >> [Tienes que estar registrado y conectado para ver este vínculo]

puede ser util para los que tienen versiones anteriores a XL2007

_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional

GalileoGali
Admin

Masculino Cantidad de envíos : 1962
Edad : 61
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: problema con suma producto

Mensaje por GalileoGali el Mar Sep 28, 2010 8:06 am

Hoja1

 BCDE
615-Maysipera, manzana, platano15
715-Febnopera, manzana40
813-Mar uva20
920-Junsiuva, manzana12
10    
1115-Ene   
12    
1315   
Spreadsheet Formulas
CellFormula
B13=SUMAR.SI.CONJUNTO(E6:E9;B6:B9;">"&B11;C6:C9;"SI";D6:D9;"*pera*")


Excel tables to the web >> [Tienes que estar registrado y conectado para ver este vínculo]

Muy, Muy practica

_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional

GalileoGali
Admin

Masculino Cantidad de envíos : 1962
Edad : 61
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: problema con suma producto

Mensaje por Tatayayan el Mar Sep 28, 2010 10:41 am

Ver esto:
=SUMAPRODUCTO(--(B6:B9>J4);--(C6:C9="SI");(E6:E9);--NO(ESERROR(ENCONTRAR("pera";D6:D9))))

Tatayayan
Moderador
Moderador

Masculino Cantidad de envíos : 319
Ciudad - Pais : Chamical- La Rioja - ARG
Fecha de inscripción : 20/11/2008

Volver arriba Ir abajo

Re: problema con suma producto

Mensaje por Contenido patrocinado Hoy a las 12:39 pm


Contenido patrocinado


Volver arriba Ir abajo

Ver el tema anterior Ver el tema siguiente Volver arriba


 
Permisos de este foro:
No puedes responder a temas en este foro.