............ Foro Excel
Si no lo has hecho aún: REGISTRATE!!!

Sumatorias Sinteticas de Productos condicionados

Ver el tema anterior Ver el tema siguiente Ir abajo

Sumatorias Sinteticas de Productos condicionados

Mensaje por GalileoGali el Dom Oct 24, 2010 10:37 am

Por ejemplo tengo una Tablita en A1:B4 que especifica fechas a partir de las cuales se debe percibir un determinado valor. En F1:F6, se encuentra la Tabla de Parciales que para cada fecha de cobro Busca el Valor correspondiente segun la anterior Tablita. Luego la Suma. Ahora bien como hacer para directamente obtener idéntico resultado pero sin cálculos auxiliares, en una sola celda.
ver E10 Y e12.

Hoja1

 ABCDEF
1DesdeValor  FechasValor Correspondiente
201/01/2010300  04/01/2010300
303/04/2010400  03/03/2010300
406/06/2010500  03/04/2010400
5    05/05/2010400
6    06/07/2010500
7     1900
8      
9    Formula Sintetica 
10    1900 
11    Otra con COINCIDIR Y FRECUENCIA 
12    1900 
Spreadsheet Formulas
CellFormula
F2=BUSCARV(E2;$A$2:$B$4;2)
F3=BUSCARV(E3;$A$2:$B$4;2)
F4=BUSCARV(E4;$A$2:$B$4;2)
F5=BUSCARV(E5;$A$2:$B$4;2)
F6=BUSCARV(E6;$A$2:$B$4;2)
F7=SUMA(F2:F6)
E10=SUMAPRODUCTO(BUSCAR(E2:E6;A2:A4;B2:B4))
E12=SUMAPRODUCTO(FRECUENCIA(COINCIDIR(E2:E6;A2:A4);FILA(B2:B3)-FILA(B2)+1)*B2:B4)


Excel tables to the web >> [Tienes que estar registrado y conectado para ver este vínculo]


_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional
avatar
GalileoGali
Admin

Masculino Cantidad de envíos : 1963
Edad : 62
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: Sumatorias Sinteticas de Productos condicionados

Mensaje por Tatayayan el Dom Oct 24, 2010 12:57 pm

Otra alternativa (con desventajas)
=SUMA(ELEGIR(COINCIDIR(E2:E6;A2:A4;1);B2;B3;B4))
avatar
Tatayayan
Moderador
Moderador

Masculino Cantidad de envíos : 319
Ciudad - Pais : Chamical- La Rioja - ARG
Fecha de inscripción : 20/11/2008

Volver arriba Ir abajo

Re: Sumatorias Sinteticas de Productos condicionados

Mensaje por GalileoGali el Dom Oct 24, 2010 3:48 pm

Muy Bein, pero como bien aclara Tatayayan, con alguna desventaja; 1) es inevitale la entrada matricial CTRL+MAYUSC + ENTER
2) SOPORTA SÓLAMENTE 29 parametros, en este ejemplo sería imponer que la lista de inicoen B2 no se extendiera más allá de B30

_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional
avatar
GalileoGali
Admin

Masculino Cantidad de envíos : 1963
Edad : 62
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: Sumatorias Sinteticas de Productos condicionados

Mensaje por Tatayayan el Dom Oct 24, 2010 8:03 pm

Como dice el Galie me faltó aclarar de lo de matricial y que la función ELEGIR soporta 29 parámetros.
avatar
Tatayayan
Moderador
Moderador

Masculino Cantidad de envíos : 319
Ciudad - Pais : Chamical- La Rioja - ARG
Fecha de inscripción : 20/11/2008

Volver arriba Ir abajo

Re: Sumatorias Sinteticas de Productos condicionados

Mensaje por Tatayayan el Lun Oct 25, 2010 12:31 pm

Gali, una pregunta cuantas son las funciones que ap sesar no ser matriciales pueden devovler una matriz, por ejemplo COINCIDIR, devuelve un matriz, BUSCAR también.
Esto viene a que indice no devuelve una matriz, según mi lógica esto estaría bien, pero no es así:

=SUMA(INDICE(b2:b4;COINCIDIR(E2:E6;A2:A4;1);1)
O
=SUMAproducto(INDICE(b2:b4;COINCIDIR(E2:E6;A2:A4;1);1)

Si INDICE devolviera una matriz el resultado sería 1900
avatar
Tatayayan
Moderador
Moderador

Masculino Cantidad de envíos : 319
Ciudad - Pais : Chamical- La Rioja - ARG
Fecha de inscripción : 20/11/2008

Volver arriba Ir abajo

Re: Sumatorias Sinteticas de Productos condicionados

Mensaje por GalileoGali el Lun Oct 25, 2010 5:49 pm

Convengamos en que el tema da para mucho, y para dar lugar a algunas interpretaciones encontradas. Creo que más que definiciones convendría describir la forma de operar de determinadas funciones respecto a la Matricialidad

a) COINCIDIR(1er arg VALOR A BUSCAR; 2DO Arg Vector (Rango Unidimensional) donde Buscar el 1er Arg; 3er argumento define una cuestion de Criterio Posicional).
Es decir la Función esta creada para Buscar UN VALOR, es decir 1er arg en el uso habitual es un UNICO VALOR. de ahi que podamos decir que COINCIDIR no es NATURALMENTE MATRICIAL, sino que puede Operar Matrcialmente si la OBLIGAN.ES DECIR SI INTRODUCES una matriz en ese primer argumento y con CTRL+MAYUSC+ENTER, obtienes Multiples resultados para cada valor introducido...

b) INDICE (1ER Arg es una Matriz, 2do arg es un Numero, tercero es un Numero; 4to es un Numero). Es decir el 1er arg es Naturalmente Una Matriz, si COINCIDIR la Pasa una MATRIZ, "le hace cosquillas", ya que INDICE tiene por COSTUMBRE manejar Matrices y al encontrar exactamente eso, no ofrecera una MATRIZ de RESULTADOS, sino uno solito, buscando solo el (1,1) de la Matriz que le ofrece COINCIDIR
(hago un llamado y despues la seguimos)



Última edición por GalileoGali el Lun Oct 25, 2010 10:22 pm, editado 2 veces

_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional
avatar
GalileoGali
Admin

Masculino Cantidad de envíos : 1963
Edad : 62
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: Sumatorias Sinteticas de Productos condicionados

Mensaje por GalileoGali el Lun Oct 25, 2010 6:27 pm

(Muy a pesar de mi teoría INDICE no respeta fielmente mi definicion, ya que nunca he logrado que funcione algo como esto, sobre los argumentos "No Naturalmente matriciales" (es decir no matriciales por diseño de la funcion) los tres últimos, probando algo como esto con CTRL+MAYUS+ENTER
=SUMA(INDICE(A1:A6;E1:F1)), FRACASO, Tambien lo intente con el tercer termino, el que establece un AREA, No funcionó. En mensaje privado hube de consultar a KL, quien me dijo que desistiera de intentar encontrar Matricialidad con INDICE
No obstante, y aunque parezca paradójico dentro de INDICE PUEDE OPERARSE con MATRICES, particularmente en el primer argumento, y en primer grado de operacion sin necesidad de introducir CTRL+MAYUSC+ENTER

BUSCAR
1ER Arg Un valor

2 y 3ero (opcional) Matrices. La matricialidad aparece entonces cuando intentamos pasar una MATRIZ dentro del Primer argumento. desde ya que no puede pretenderse Matrcialidad sobre los otrso dos argumentos ya que Naturalmente han sido diseñados para admitir matrices. Ahora bien yo creo que BUSCAR es la primera funcion de diseño matrcial, ya que opera entre dos vectores (aun cuando no lleve 3er vector) con una asignacion "en espejo"

la sigo mas tarde

_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional
avatar
GalileoGali
Admin

Masculino Cantidad de envíos : 1963
Edad : 62
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: Sumatorias Sinteticas de Productos condicionados

Mensaje por Tatayayan el Lun Oct 25, 2010 10:02 pm

EXCELente Explicaión, valoré tu explicación. Muchísima Gracias.
avatar
Tatayayan
Moderador
Moderador

Masculino Cantidad de envíos : 319
Ciudad - Pais : Chamical- La Rioja - ARG
Fecha de inscripción : 20/11/2008

Volver arriba Ir abajo

Re: Sumatorias Sinteticas de Productos condicionados

Mensaje por GalileoGali el Lun Oct 25, 2010 10:19 pm

SUMAPRODUCTO: un caso donde el diseño original la hace Matricial por Nacimiento, a punto tal que muchas (no todas las veces, nos ahorra entradas matriciales (CTRL+MAYUS+ENTER) por imbuir de este tratamiento a las Matriciales tanto Naturales (invocadas desde Rangos directos) o tal vez como MATRICIALES "Obligadas".

Funciones Resumen: son las que aglutinan la Matriz generada dando un resultado para Exhibir en una Celda: SUMA, PROMEDIO, MAX, MIN (un caso aparte ya que los molestos "0", complican su uso), SUMAPRODUCTO ya viene con la Funcion RESUMEN incorporada.
Otra Matricial con RESUMEN INCORPORADO ES MMULT, que a partir de Matrices de determinado tamaño, tambien da un resultado unico.
Esto de las funciones resumen, se contrapone a otra variedad de funciones que a partir de Matrices dan por resultado otra matriz, o vector son funciones generalmente de R (n*m)>>>R (n) o a R(j), entre estas hay varias de las llAmadas estadisticas: TENDENCIA, PRONOSTICO, FRECUENCIA, que son matriciales "a rango" es decir, en lugar de RESUMIR los datos mediante una suma un PROMEDIO, etc, devuelven una Tabla de resultados

Otro capitulo merecen las Funciones del Paquete "Analisys Tool Pak" que en consulta (en un ingles de sioux, de mi parte) que me atrevi a hacer en privado a al flamante MS Excel MVP, don Aladyn Akyurek, me menciono que las Naturalmente no Matriciales, de este paquete ("Herramientas para análisis"), no aceptaban matricializarse via entradas CTRL+MAYUSC+ENTER

_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional
avatar
GalileoGali
Admin

Masculino Cantidad de envíos : 1963
Edad : 62
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: Sumatorias Sinteticas de Productos condicionados

Mensaje por Contenido patrocinado


Contenido patrocinado


Volver arriba Ir abajo

Ver el tema anterior Ver el tema siguiente Volver arriba


 
Permisos de este foro:
No puedes responder a temas en este foro.